Aufruf von „HostDatastoreSystem.QueryVmfsDatastoreCreateOptions“ für Objekt „ha-datastoresystem“ auf ESXi „XXX.XXX.XXX.XXX“ ist fehlgeschlagen.

Beim Anlegen eines VMFS-Datenspeichers bin ich gestern auf die folgende Fehlermeldung gestoßen:

Aufruf von "HostDatastoreSystem.QueryVmfsDatastoreCreateOptions" für Objekt "ha-datastoresystem" auf ESXi "XXX.XXX.XXX.XXX" ist fehlgeschlagen.

Zuerst dachte ich an das frisch über den HP RAID-Controller angelegte logische Laufwerk, doch das war intakt und wurde von ESXi fehlerfrei erkannt:

=> ctrl slot=1 pd all show status

 physicaldrive 2I:0:5 (port 2I:box 0:bay 5, 500 GB): OK
 physicaldrive 2I:0:6 (port 2I:box 0:bay 6, 500 GB): OK
 physicaldrive 2I:0:7 (port 2I:box 0:bay 7, 250 GB): OK
 physicaldrive 2I:0:8 (port 2I:box 0:bay 8, 250 GB): OK

=> ctrl slot=1 ld all show status

 logicaldrive 1 (465.7 GB, 1): OK
 logicaldrive 2 (232.9 GB, 1): OK

Nach einigen Recherchen im Internet habe ich gelesen, dass auch ein fehlerhaftes GPT-Label die Ursache des Übels sein kann – das Neuformatieren mithilfe der gParted Live-CD würde hier Abhilfe schaffen. Doch ein Reboot kam natürlich nicht in Frage – nicht zuletzt, weil ESXi ohnehin auch über das parted-Tool verfügt und das selbstständig erledigen kann. Benötigt wird lediglich die Gerätedatei des logischen Laufwerks mit der fehlerhaften GPT-Tabelle – wer dieses nicht kennt, kann es mit fdisk herausfinden, indem er nach dem Laufwerk mit der passenden Größe sucht:

# fdisk -l
# partedUtil mklabel /dev/disks/naa.xxx gpt

Nach der Neu-Erstellung des GPT-Labels funktionierte das Anlegen bei mir fehlerfrei. 🙂

Sharing is caring

27 Kommentare Schreibe einen Kommentar

  1. Ganze Arbeit, Christian!
    Hab für kleines Geld nen P410i in meinen N40L genagelt und dachte schon, es tut nicht, aber dann habe ich deinen Thread gelesen und nun tuts einwandfrei 🙂
    Vielen Dank und Grüße aus Wolfsburg!

    • Hallo Enrico,

      vielen Dank für dein Feedback! Freut mich wirklich, dass ich Dir helfen konnte. 🙂

      Wünsche noch viel Spaß mit dem Würfelserver. 😉

      Beste Grüße aus Hessen,
      Christian.

  2. Mit den Befehlen fdisk -l und partedUtil wie angegeben konnte ich die Festplatten (RAID1) zum VMWARE-Speicher wunderbar hinzufügen .
    Dämlich, dass da VMware so ablust und so eine beknackte Fehlermeldung bringt. Aber wenns dann Dank Google und einiger Leidensgenossen läuft, sei es VMware verziehen. Ansonsten ja ne tolle Software, besser noch als derzeit Hyper-V . Ich denke da nur an die vmconverter und sonstige super Tools.
    Schönen Gruß aus Ingolstadt

  3. Hallo Christian,

    vielen Dank!
    Sogar ich als vmware-anfänger, konnte dank ihres blog-eintrages den fehler in meinem vmware test-host beseitigen.

Schreibe einen Kommentar